Instalación de Paquetes ORE 1.4.1.

Cuento corto: Oracle R Enterprise es una herramienta que integra al lenguaje de programación R con la base de datos Oracle y en este post veremos como instalar las librerías del cliente y de soporte de ORE 1.4.1 en Windows. Primeramente, vamos a descargar las librerías cliente desde aquí y las librerías de soporte desde acá. Posteriormente, corremos el siguiente script no sin antes cambiar las líneas 18 y 19 por los directorios donde se sitúan las librerías descargadas.

finstall <- function( path )
{
# Fijar directorio
setwd( dir = path )
# Listar archivos zip
files <- list.files( path = path, full.names = T )
# Por cada fichero, instalar
for( f in files )
{
cat('Installing ', f )
install.packages( pkgs = f, repos = NULL )
}
}
# Fijar directorios
finstall( 'directorioLibreriasCliente' )
finstall( 'directorioLibreriasSoporte' )
view raw instalarPaquetes.R hosted with ❤ by GitHub

Instaladas las librerías, pasamos a descargar el Instant Client de Microsoft Windows. Selecciona la versión de 64 o 32 bits, dependiendo de tus necesidades. Luego, descarga el Instant Client Basic y el Instant Client SDK. Primero descomprime el Basic, y seguido de ello descomprime los contenidos del SDK dentro de la carpeta Basic, a fin de situar los contenidos de ambos clientes en un mismo directorio. Por último, fija las variables de ambiente OCI_LIB64 y PATH al directorio que contiene los archivos descomprimidos(C:/…/../…./../instantclient_12_1). Abre una sesión nueva de R e invoca la librería ORE. Listo.

library( package = 'ORE' )
Loading required package: OREbase
Attaching package:OREbase
The following objects are masked frompackage:base:
cbind, data.frame, eval, interaction, order, paste, pmax, pmin, rbind, table
Loading required package: OREembed
Loading required package: OREstats
Loading required package: MASS
Loading required package: OREgraphics
Loading required package: OREeda
Loading required package: OREmodels
Loading required package: OREdm
Loading required package: lattice
Loading required package: OREpredict
Loading required package: ORExml
view raw library.R hosted with ❤ by GitHub

2 comentarios en “Instalación de Paquetes ORE 1.4.1.

Deja un comentario